mm91

Plus de page d"'index" depuis une semaine
« le: 29 septembre 2014 08:54:59 »

Sur mon site perso (site météo) je télécharge régulièrement des fichiers "…DAT"
ils se trouvent dans le dossier/sous dossiers " meteo/fichiersWswin32/WsWin"

à l'adresse suivante:

http://icare.cinq.free.fr/meteo/fichiersWswin32/WsWin/?M=D

Depuis des années lorsqu'on appelait cette adresse il apparaissait une page d'"index" comprenant la liste de tous les fichiers "…DAT"  (129 fichiers = 75 Mo actuellement).

Depuis une semaine cette liste n'apparaît plus et une erreur 403 est retournée à la place (comme vous pouvez le constater).

Je précise bien que ces fichiers sont toujours sur mon site, que je peux en télécharger de nouveau sans problème et que j'ai bien leur liste quand j'accède à mon site avec File Zilla par exemple.

Par exemple le fichier nommé: " WD_08_14.DAT" (c'est l'un des 129 fichiers)
est bien accessible à l'adresse:

http://icare.cinq.free.fr/meteo/fichiersWswin32/WsWin/WD_08_14.DAT 

comme vous pouvez le constater.

(c'est un fichier "machine" si vous l'ouvrez (avec bloc note par exemple) vous n'y verrez que du code. Il n'est utilisable qu'avec le programme "Wswin32").

L'affichage de cette liste est indispensable lorsqu'on veut choisir parmi les (129) fichiers proposés.

Pourquoi cette liste n'apparaît plus ?
Y a-t-il eu quelque chose de changé chez Free? si oui pourquoi ?
Où puis-je m'adresser pour demander le rétablissement de cette liste ?

cartomi

Re : Plus de page d"'index" depuis une semaine
« Réponse #1 le: 29 septembre 2014 12:11:05 »
Oui, il y a eu une modif chez Free pour faire disparaitre la liste d'index
une instruction Options +Indexes dans un fichier .htacces devrait rendre ce listage possible.

Ceci étant ce type d'usage n'est pas permis sur les pages perso Free (c'est indiqué lors de la création) qui doivent être utilisées pour concevoir un vrai site web avec du contenu et une ligne éditoriale.


mm91

Re : Re : Plus de page d"'index" depuis une semaine
« Réponse #2 le: 29 septembre 2014 14:52:22 »
Merci Cartomi pour cette réponse rapide.

Oui, il y a eu une modif chez Free pour faire disparaitre la liste d'index
une instruction Options +Indexes dans un fichier .htacces devrait rendre ce listage possible.

Je ne comprends pas bien; cette solution est-elle applicable par Free ou par moi ?
Dans le premier cas, merci à Free de l'appliquer !
Dans le second cas peux-tu me décrire plus précisément ce que je dois faire ?

Citer
Ceci étant ce type d'usage n'est pas permis sur les pages perso Free (c'est indiqué lors de la création) qui doivent être utilisées pour concevoir un vrai site web avec du contenu et une ligne éditoriale.
Je pense respecter les conditions d'utilisation d'un site perso Free puisque tous mes fichiers (comme toutes mes pages) sont accessibles au public à partir de ma page d'accueil (voir en bas à droite: "tous les fichiers de donnée météo") ici: http://icare.cinq.free.fr/meteo/
(Ce n'est pas simplement un espace personnel de stockage de fichier)
Et d'ailleurs l'accès à une liste facilite encore plus l'accès publique; donc on tourne un peu en rond !

cartomi

Re : Plus de page d"'index" depuis une semaine
« Réponse #3 le: 29 septembre 2014 17:43:25 »
le .htaccess c'est à vous de le faire. Comme c'est un fichier essentiel, vous trouverez sur le web nombre tutos qui décrivent ses possibilités. vous avez ici quelques pistes : http://les.pages.perso.chez.free.fr/index.php/go/1l

Normalement a la racine de vos pages il devrait y avoir un index créé par vos soins puisque c'est ce fichier que va rechercher un navigateur lorsque vous lui donnez l'url http://icare.cinq.free.fr
Free avait choisi de laisser apache générer ce fichier lorsqu'il était absent,  ce qui n'etait qu'un pis aller dangereux puisqu'il permettait aux moteur de recherche de les indexer.

Pour le reste je n'ai nullement l'intention de polémiquer, c'était juste une mise en garde : tous les fichier présents sur votre espace perso doivent participer directement à la vie du site et donc doivent pouvoir être exploités par un navigateur. S'il y a téléchargement possible ce doit être depuis un lien sur une page web.
la "conformité" des pages perso free est developpée ici : http://les.pages.perso.chez.free.fr/index.php/go/0l
Sauvegardes et fichiers logs sont proscrits


mm91

Re : Plus de page d"'index" depuis une semaine
« Réponse #4 le: 29 septembre 2014 21:21:43 »
merci beaucoup.

mm91

Re : Plus de page d"'index" depuis une semaine
« Réponse #5 le: 02 octobre 2014 09:46:11 »
Grâce au lien que vous m'avez indiqué (utilisation de ".htaccess)
j'ai pu rétablir ma page d'index (liste des fichiers), ici:
http://icare.cinq.free.fr/meteo/fichiersWswin32/WsWin/?M=D

encore un très grand MERCI

jeantend

Re : Plus de page d"'index" depuis une semaine
« Réponse #6 le: 31 décembre 2014 08:18:47 »
Bonjour,
Que faut il écrire exactement dans le htaccess ?
J'ai essayé Options +Indexes mais je me retrouve avec une erreur 500
J'ai essayé d'autres choses sans plus de résultat, si quelqu'un peut me dire quoi écrire exactement dans le htaccess ce serait très sympa
Merci,


jeantend

Re : Plus de page d"'index" depuis une semaine
« Réponse #7 le: 31 décembre 2014 09:10:13 »
ah cool j'ai réussi !
pour ceux que ça intéresserait j'ai juste mis ça dans le htaccess à la racine du site
<IfDefine Free>
php 1
</IfDefine>
Options +Indexes

mm91

Re : Plus de page d"'index" depuis une semaine
« Réponse #8 le: 31 décembre 2014 10:39:39 »
bonjour Jeantend

dans ma page nommée:

.htaccess

j'ai écrits seulement:

Options Indexes

et ça marche.

PS:
 j'ai bien eu ton MP mais n'ai pas répondu puisque je réponds ici.

jeantend

Re : Plus de page d"'index" depuis une semaine Nouveau
« Réponse #9 le: 05 janvier 2015 09:50:33 »
ok merci mm91
de mon coté quand j'écrivais ça, le texte du htaccess était supprimé (par Free ?) et j'avais une erreur 500 avant que ce soit supprimé ; j'ai pas bien compris quand et pourquoi ce texte se supprimait, si c'était différent à la racine du site ou dans des répertoires.
Bref étrange, je ne maitrise pas toutes les subtilités du htaccess
« Modifié: 05 janvier 2015 09:52:29 par jeantend »