Aliscan

Solution pour les problemes de ports pour le multiposte
« Réponse #450 le: 13 janvier 2006 17:33:05 »
Je n'ai toujours pas ma réponse au défilement des chaînes moi ...

Aldo

Solution pour les problemes de ports pour le multiposte
« Réponse #451 le: 13 janvier 2006 17:50:29 »
Bonjour,

Configuration : Freebox, Routeur netgear, PC.

Après 3 jours de galère, j'ai fait exactement les mêmes opérations qu'Armelle sans l'étape 3.

Ca marche, la liste des chaînes est chargée, la vidéo se lance sur Antenne 2, mais impossible de changer de chaîne les messages indiquent :

livedotcom debug: no data received in 10s. Switching to TCP
livedotcom debug: RTP subsession 'video/MP2T'
livedotcom error: PLAY failed No RTSP session is currently in progress

livedotcom error: TCP rollover failed, aborting

et VLC essaye de passer à la chaîne suivante et là même probléme.

Quelqu'un a t-il déjà rencontré ce cas ?

Merci d'avance pour toute idée car j'en trouve plus.

darkpopcorn

Solution pour les problemes de ports pour le multiposte
« Réponse #452 le: 14 janvier 2006 00:30:38 »
Salut à tous,


Moi j'ai un routeur Linksys WRT54GX + XP SP2 + vlc version crazyfred

redirection des port 31336->31337 en udp vers l'adresse de ip de mon poste.

Tout est ok du 1er coup.


Merci à crazyfred...
^^

glasswalker

Solution pour les problemes de ports pour le multiposte
« Réponse #453 le: 14 janvier 2006 08:58:28 »
j'y arrivais pas mais là c'est bon merci à tous


glasswalker

Solution pour les problemes de ports pour le multiposte
« Réponse #454 le: 14 janvier 2006 09:14:02 »
euh non finalement j'y suis parvenu un peu grace à darkpopcorn
merci à tous

Aldo

Solution pour les problemes de ports pour le multiposte
« Réponse #455 le: 15 janvier 2006 11:06:04 »
Bonjour,

finalement, j'ai réussi a tout faire marcher.

Il faut faire toutes les étapes indiquées par ARMELLE sauf la 3 et la 5 comme indiqué par KAMUI.

Le problème venait de mon firewall Zone Alarm.

j'ai activé dans l'onglet FW de ZA tous les ports vers le 31336 en UDP pour l'@ip de la freebox vers l'@IP du PC.

depuis plus d'erreur :

livedotcom debug: no data received in 10s. Switching to TCP
livedotcom debug: RTP subsession 'video/MP2T'
livedotcom error: PLAY failed No RTSP session is currently in progress
livedotcom error: TCP rollover failed, aborting

Merci a tous pour les posts sur le sujet, ça aide bien a faire avancer le sujet.

Salut a tous.

Trussart Sébastien

Solution pour les problemes de ports pour le multiposte
« Réponse #456 le: 16 janvier 2006 10:07:49 »
Salut tout le monde,

Suite à quelques tests que j'ai fait depuis une bonne semaine, je viens de trouver mon erreur sur mon routeur WGR614v5 de chez Netgear.

En fait, il suffisait de faire un trigger du port 554 (externe) vers les ports 31336 et 31337 (interne) en UDP bien sur.

Peut-être que cela pourrait aider certains, surtout ceux qui, comme moi, avaient les 10 secondes d'attente avant que VLC ne change de chaine.

Mon test a été effectué depuis un poste sous XP SP2 avec aucun firewall d'actif sur celui-ci.

Bon courage à tous.

Au fait, j'en profite pour dire merci à CrazyFred au passage pour son VLC modifié et en même temps, et de dire merci à l'équipe des développeurs de ADSLTv et FreeTvVcr pour leur module d'enregistrement.

Bonne journée à tous et merci Free ...


PsYKrO

Solution pour les problemes de ports pour le multiposte
« Réponse #457 le: 18 janvier 2006 11:40:11 »
Salut à Tous,

Ben moi ça marche apres 4H d'étude! le seul probleme je peux regardé la TV que sur un seul poste... ou bien je peux regarder la même chaine sur plusieurs postes (donc pas très utile si tout le monde doit regardé la même chaine autant se regrouper !! lol)

Config: Freebox (bridge) + Routeur Lynksys WRT54gs V4 (firmware DD-WRT 23 final + VPN)

je suis connecté en WIFI et en Filaire et aucun problème si qu'un PC regarde la TV que ce soit WIFI ou filaire.

Routeur: Routage du port 31336-31337 vers mon PC filaire
             Routage du port 31338-31339 vers mon PC Wifi
             Trigerring 554 554 ----> 31336-31339

Ensuite, j'utilise la version de VLC crazy Fred avec sur chaque PC la configuration du port UDP.
J'utilise un skin FreeVcr il me semble ...

bref, pas moyen d'avoir 2 pc avec 2 chaines différentes...

J'ai eu une idée aujourdhui mais je n'ai pas testé... je vais le faire ce soir...

On pose le problème: Si j'ai la TV sur chaque PC mais pas en simultané ca veut dire que mon routage et mes firewall sont bons...

Donc il me semble que c'est un problème de brodcast? non ? je sais que j'ai coché Filter Broadcoast donc mon idée vient de là ...(je test ce soir)

Sinon vous avez des idées?

PS: rien à voir avec le sujet mais ca peut servir... j'avais coché filter cookies, et mes parents ne pouvaient plus se connecter sur leur site de jeux yahoo... en enlevant le filter.... ca remarché... c'est dommage qu'il est pas un systele de gestion de cookies avec le firmware DD-WRT 23 final + VPN

kamui

Solution pour les problemes de ports pour le multiposte
« Réponse #458 le: 18 janvier 2006 12:41:00 »
Citation de: PsYKrO
Config: Freebox (bridge) + Routeur Lynksys WRT54gs V4 (firmware DD-WRT 23 final + VPN)

je suis connecté en WIFI et en Filaire et aucun problème si qu'un PC regarde la TV que ce soit WIFI ou filaire.

Routeur: Routage du port 31336-31337 vers mon PC filaire
             Routage du port 31338-31339 vers mon PC Wifi
             Trigerring 554 554 ----> 31336-31339
encore un qui n'a pas compris que le port triggering ne fonctionne que sur une machine à la fois! ,
donc supprime ton port trigerring , et ouvre un port udp différent  sur chacune de tes machines avec la version vlc de crazy fred ou de nightly et forward ces port sur ton routeur .

ex : Routage du port udp 48152 vers ton PC filaire (fixe ce port udp sur la machine avec le vlc de crazyfred)
       Routage du port udp 48158 vers ton PC Wifi (fixe ce port udp sur la machine avec le vlc de crazyfred)

pour changer le port udp sur crazy fait comme ci dessous
http://img350.imageshack.us/img350/4499/d4kz.png

Et la sa devrait fonctionner en même temps et tu pourras mater des chaines différents , donc avant de vouloir la TV sur plusieurs poste en meme temps , d'abord vérifie ton débit max ! , le flux prends 3Mbits envirion (350Ko/s par flux) , donc pour avoir 8 flux maxi faut un ligne qui synchro à 24 MBits .

Pour ma part c 2 flux maxi car je synchronise qu'à 8270Kbits :(

et perso je te conseille de changer de firmware car j'ai testé les DD WRT 23 final , çà fait pas long feu avec le P2P , je te conseille Thibor 12 ;) qui est roxx stable sur mon WRT54GS rev 1.1

PsYKrO

Solution pour les problemes de ports pour le multiposte
« Réponse #459 le: 18 janvier 2006 13:04:44 »
ah d'accord donc il y a que des redirections a faire finalement...
et si je n'ai pas compris c'est que ce n'est pas clair ... et je ne suis pas le seul dans ce cas...


Pour ma part, le DD-WRT 23 final me pose aucun problème mais j'ai pas testé la mule, de toute facon je télècharge quasiment pas... en p2p (1 fois dans le mois lol donc forcement j'ai pas vu de problème de stabilité... mais vu que j'ai fait une connerie ne mettant une firmware et mon routeur était HS alors maintenant je fais attention .... je vais allé voir ce firmware dont tu me parles...

As tu testé le VPN avec le DD ou le Thibor ?


EDIT:

JE viens d'aller voir ton firmware ... il a pas l'air complet du tout... pour ma part il me faut le SSH au moins avec clé d'authentification, VPN (openvpn) sur le site que j'ai lu pour l'instant ce firmware ne le fait pas... j'ai pas testé le firmware DDWRT avec le p2p mais je pense que si c'est chez toi ca marche pas... je vois pas pourquoi chez moi ca marcherai ... je teste ce soir... Apres tout est question de choix et priorité... en tout cas le torrent marche parfaitement...

Daniel0312

Solution pour les problemes de ports pour le multiposte
« Réponse #460 le: 18 janvier 2006 13:16:33 »
Salut à tous, et merci pour le travail.

Bon, j'ai tout lu! si si tout! et tout compris.
Tout, pas tout à fait!
Il reste quelque chose que je ne comprends pas: ça ne fonctionne toujours pas chez moi. Enfin pas vraiment.

Freebox v4 degroup total, routeur Netgear FVS124G.
CGV, 24h, reboot, reboot...
VLC crazy, ports forwardés... tout bien.

Je ne peux afficher que certaines chaînes!!!

156 La Locale
240 Rai Uno
301 France 3 Alsace
304 France 3 Auvergne
306 France 3 Bretagne
310 France 3 Côte-d'Azur
312 France 3 Languedoc-Roussillon
316 France 3 Nord Pas-de-Calais
317 France 3 Haute-Normandie
321 France 3 Picardie

Y a-t-il quelqu'un pour m'aider??
Ceux qui ont un routeur Netgear et des problèmes, ont-ils essayé les chaines ci-dessus?

Merci d'avance

kamui

Solution pour les problemes de ports pour le multiposte
« Réponse #461 le: 18 janvier 2006 16:48:57 »
Citation de: PsYKrO
ah d'accord donc il y a que des redirections a faire finalement...
et si je n'ai pas compris c'est que ce n'est pas clair ... et je ne suis pas le seul dans ce cas...


Pour ma part, le DD-WRT 23 final me pose aucun problème mais j'ai pas testé la mule, de toute facon je télècharge quasiment pas... en p2p (1 fois dans le mois lol donc forcement j'ai pas vu de problème de stabilité... mais vu que j'ai fait une connerie ne mettant une firmware et mon routeur était HS alors maintenant je fais attention .... je vais allé voir ce firmware dont tu me parles...

As tu testé le VPN avec le DD ou le Thibor ?


EDIT:

JE viens d'aller voir ton firmware ... il a pas l'air complet du tout... pour ma part il me faut le SSH au moins avec clé d'authentification, VPN (openvpn) sur le site que j'ai lu pour l'instant ce firmware ne le fait pas... j'ai pas testé le firmware DDWRT avec le p2p mais je pense que si c'est chez toi ca marche pas... je vois pas pourquoi chez moi ca marcherai ... je teste ce soir... Apres tout est question de choix et priorité... en tout cas le torrent marche parfaitement...
c sur qu'il est moins complet que DDWRT ,pour le vpn ,je me contente de celui xp qui fonctionne trés bien.

et DDWRT24 final sera payant pour avoir toutes les fonction :(

PsYKrO

Solution pour les problemes de ports pour le multiposte
« Réponse #462 le: 19 janvier 2006 09:17:09 »
Citation de: kamui
[
c sur qu'il est moins complet que DDWRT ,pour le vpn ,je me contente de celui xp qui fonctionne trés bien.
Oui il marche nikel mise à part qu'il ne gere pas les multiconnections... sauf si tu as un windows server mais le Windows XP pro ne sait pas le faire... alors jouer à deux....c'est chiant ... ^^

Enfin c'est un autre sujet....

Merci en tout cas, effectivement ca marche maintenant (multiposte)....

azer

Solution pour les problemes de ports pour le multiposte
« Réponse #463 le: 19 janvier 2006 10:33:59 »
Daniel0312, moi j'ai un souci similaire, sauf que moi je ne reçois rien du tout !!!

Voilà, j'ai la freebox en mode normal relier a mon routeur netgear WPNT834. De ce routeur partent 2 cables reseau
en filaire et 1 pc en wifi.

J'ai finalement récupéré la version de crazy (celle avec le port modifiable) et l'ai configuré sur le 31336.

Voilà ma configuration du routeur :



Le freeplayer fonctionne nickel, et je tiens à préciser que le multiposte fonctionne nikel quand l'ordi est branché en direct sur la freebox.
Donc la fameuse condition du "il faut impérativement que la freebox soit en mode routeur pour que le multiposte fonctionne" n'est pas vraie.

Et j'ai grand besoin d'aide svp ...


kamui

Solution pour les problemes de ports pour le multiposte
« Réponse #464 le: 19 janvier 2006 11:01:37 »
vire le port triggering ! et ton port forward ,? il vas sur quel IP 192.168.1.2 ?. tu la masqué exprés ?

j'ai expliquer la soluce pour les routeurs deux post plus haut ! c pour le linksys mais je pense que sa doit être la meme chose avec les autre routeur !

kamui

Solution pour les problemes de ports pour le multiposte
« Réponse #465 le: 19 janvier 2006 11:02:24 »
Citation de: PsYKrO
Citation de: kamui
[
c sur qu'il est moins complet que DDWRT ,pour le vpn ,je me contente de celui xp qui fonctionne trés bien.
Oui il marche nikel mise à part qu'il ne gere pas les multiconnections... sauf si tu as un windows server mais le Windows XP pro ne sait pas le faire... alors jouer à deux....c'est chiant ... ^^

Enfin c'est un autre sujet....

Merci en tout cas, effectivement ca marche maintenant (multiposte)....
au plaisir ;)

azer

Solution pour les problemes de ports pour le multiposte
« Réponse #466 le: 19 janvier 2006 11:33:18 »
non en fait c'est du 192.168.7.x

mon routeur est bien configuré, j'en suis certain. les ips sont bonnes et les forward aussi.

Mais toujours impossible de recevoir le flux ... :

livedotcom debug: RTP subsession 'video/MP2T'
livedotcom error: PLAY failed No RTSP session is currently in progress

main warning: no access_demux module matching "rtsp" could be loaded
main debug: creating access 'rtsp' path='mafreebox.freebox.fr/freeboxtv/201'
main debug: looking for access2 module: 4 candidates
vcd debug: trying .cue file: mafreebox.freebox.cue
access_file warning: mafreebox.freebox.fr/freeboxtv/201: No such file or directory
cdda debug: trying .cue file: mafreebox.freebox.cue
cdda warning: could not open mafreebox.freebox.fr/freeboxtv/201
main warning: no access2 module matching "rtsp" could be loaded
main error: no suitable access module for `rtsp://mafreebox.freebox.fr/freeboxtv/201'
main debug: destroying chain... (name=duplicate)
stream_out_duplicate debug: closing a duplication
main debug: destroying chain... (name=display)
main debug: unlocking module "stream_out_display"
main debug: destroying chain done
main debug: unlocking module "stream_out_duplicate"
main debug: destroying chain done
main debug: thread times: real 0m0.171875s, kernel 0m0.015625s, user 0m0.015625s
main debug: thread 3488 joined (src/input/input.c:386)
main: nothing to play
Pourquoi ? je ne sais pas ....

Daniel0312

Solution pour les problemes de ports pour le multiposte
« Réponse #467 le: 19 janvier 2006 11:56:26 »
Citation de: azer
Daniel0312, moi j'ai un souci similaire, sauf que moi je ne reçois rien du tout !!!

Voilà, j'ai la freebox en mode normal relier a mon routeur netgear WPNT834. De ce routeur partent 2 cables reseau
en filaire et 1 pc en wifi.

J'ai finalement récupéré la version de crazy (celle avec le port modifiable) et l'ai configuré sur le 31336.

Voilà ma configuration du routeur :
http://zerros.ma.cx/forward.JPG
http://zerros.ma.cx/trigger.JPG

Le freeplayer fonctionne nickel, et je tiens à préciser que le multiposte fonctionne nikel quand l'ordi est branché en direct sur la freebox.
Donc la fameuse condition du "il faut impérativement que la freebox soit en mode routeur pour que le multiposte fonctionne" n'est pas vraie.

Et j'ai grand besoin d'aide svp ...
Rien de nouveau pour moi, par contre il y a un sujet sur le forum NETGEAR, avec un tuto, pas mal du tout.
http://www.netgear-forum.com/forum/index.php?showtopic=34015
Il semble que ça règle beaucoup de problèmes.
Bonne chance

Urmala

Solution pour les problemes de ports pour le multiposte
« Réponse #468 le: 19 janvier 2006 12:23:45 »
Bonjour,

Merci pour toutes vos indications : le multiposte fonctionne très bien sur mon portable DELL, avec un routeur Linksys WRT54GS
  - sur le routeur, le port triggering renvoie le 554 vers les ports 31336 et 31337 (aucune mention de l'adresse de mon portable)
  - sur mon portable, la version VLC de CrazyFred (que je remercie) utilise le port 31336
  - sur mon portable, les ports 31336 et 31337 sont ouverts pour l'adresse 212.27.38.253 dans le firewall de XP

Par contre j'ai un problème étrange : cela ne fonctionne correctement que si je viens de rebooter mon PC. Si je mets le PC en veille, puis que je le rallume et que je relance VLC, j'observe le défilement caractéristique des chaines.
J'ai trouvé un moyen de contourner ce problème : il "suffit" de désactiver le firewall et le défilement s'arrête avant que l'image apparaisse. Ensuite, je peux réactiver le firewall et ça continue à fonctionner jusqu'à la prochaine mise en veille du portable.
Conclusion : il doit bien y avoir un port bloqué par le firewall de XP, mais je n'arrive pas à identifier lequel, même après avoir avoir observé une trace avec Ethereal. Ma crainte, c'est que ce ne soit pas un port en particulier, mais un ensemble de ports utilisés par le procole RTSP en TCP. J'ai ouvert le port 554, mais sans résultat. Quelqu'un a-t-il une idée ?

kamui

Solution pour les problemes de ports pour le multiposte
« Réponse #469 le: 19 janvier 2006 14:44:52 »
Citation de: Urmala
Bonjour,

Merci pour toutes vos indications : le multiposte fonctionne très bien sur mon portable DELL, avec un routeur Linksys WRT54GS
  - sur le routeur, le port triggering renvoie le 554 vers les ports 31336 et 31337 (aucune mention de l'adresse de mon portable)
  - sur mon portable, la version VLC de CrazyFred (que je remercie) utilise le port 31336
  - sur mon portable, les ports 31336 et 31337 sont ouverts pour l'adresse 212.27.38.253 dans le firewall de XP
enlève le triggerring ! et ouvre qu'un seul port udp ! sur ton routeur , et sur le firewall xp pas la peine d'ouvrir le port udp , tu autorise enfin "débloque" juste VLC à allez sur le net quand il veut te bloquer


et utilise des soft comme freepvcr ou fritv pour mater la TV ;)

PsYKrO

Solution pour les problemes de ports pour le multiposte
« Réponse #470 le: 19 janvier 2006 16:57:22 »
Citation de: kamui
et utilise des soft comme freepvcr ou fritv pour mater la TV ;)
+1

Pour une configuration

FREEBOX (bridge) c'est à dire pas en routeur
+
ROUTEUR quelconque
+
WIFI OU FILAIRE


1) PREPARER LE VLC CRAZY FRED SUR CHAQUE PC AVEC PORT CLIENT UDP 31337 PC1, 31339 PC2, 31341 PC 3 (c'est un exemple)
PREPARER LE SKIN freepvcr vraiment utile !

2) Routeur faire uniquement des redirections en port FORWARDING donc dans notre cas....

NOM : VLC
PORT START: 31336-31337
TYPE: UDP
IP: 192.168.1.x (PC1)
PORT END: 31336-31337

NOM : VLC
PORT START: 31338-31339
TYPE: UDP
IP: 192.168.1.x (PC2)
PORT END: 31338-31339

NOM : VLC
PORT START: 31339-31341
TYPE: UDP
IP: 192.168.1.x (PC3)
PORT END: 31339-31341

....normalement la c'est dejà bon ...

Ensuite, comme dit kamui WINDOWS Parefeu detecte tout seul ;)

Voilà je pense que j'ai résumé...


Mon erreur a été de mettre le port trigerring... et ca je l'aurais jamais fait si j'avais pas lu les post d'avant...
Et le je tourne nikel avec 2 postes simultanés 1 en wifi l'autre en filaire et 2 chaines différentes...

CE soir j'installe un 3 eme poste... ;) et qui sait peut etre sur mon PDA ;) loool juste pour le fun ! ;)


azer

Solution pour les problemes de ports pour le multiposte
« Réponse #471 le: 19 janvier 2006 20:32:17 »
Bon ben, je le confirme alors : chez moi CA NE MARCHE PAS !!!

port forwarding : 31336 - 31337 en UDP vers @IP qui a VLC

Sur le PC : VLC CRAZY avec 31337

Port triggering marche pas avec un 54 TCP vers 1 - 65000 TCP/UDP
Port triggering marche pas avec un 54 UDP vers 1 - 65000 TCP/UDP

Même en DMZ ca ne passe pas. Je recois bien les attaques TCP et UDP, mais
pas moyen de faire fonctionner le multiposte (il faudrait déjà qu'il fonctionne sur 1 seul poste !!)

S'il existe d'autres solutions, je veux bien les connaitre.

a+

- azer -

kamui

Solution pour les problemes de ports pour le multiposte
« Réponse #472 le: 19 janvier 2006 22:27:29 »
Citation de: PsYKrO
Citation de: kamui
et utilise des soft comme freepvcr ou fritv pour mater la TV ;)
+1

Pour une configuration

FREEBOX (bridge) c'est à dire pas en routeur
+
ROUTEUR quelconque
+
WIFI OU FILAIRE


1) PREPARER LE VLC CRAZY FRED SUR CHAQUE PC AVEC PORT CLIENT UDP 31337 PC1, 31339 PC2, 31341 PC 3 (c'est un exemple)
PREPARER LE SKIN freepvcr vraiment utile !

2) Routeur faire uniquement des redirections en port FORWARDING donc dans notre cas....

NOM : VLC
PORT START: 31337
TYPE: UDP
IP: 192.168.1.x (PC1)
PORT END: 31337

NOM : VLC
PORT START:31339
TYPE: UDP
IP: 192.168.1.x (PC2)
PORT END: 31339

NOM : VLC
PORT START:31341
TYPE: UDP
IP: 192.168.1.x (PC3)
PORT END: 31341

....normalement la c'est dejà bon ...

Ensuite, comme dit kamui WINDOWS Parefeu detecte tout seul ;)

Voilà je pense que j'ai résumé...
1 port udp par machine sa suffit ;)

Urmala

Solution pour les problemes de ports pour le multiposte
« Réponse #473 le: 19 janvier 2006 23:51:50 »
Désolé, les gars, votre solution fonctionne peut-être mieux que la mienne si l'on veut pouvoir regarder simultanément la FreeTV sur 2 postes, mais moi, pour l'instant, je n'en ai qu'un...
Et les symptômes sont exactement identiques avec votre config de routeur qu'avec la mienne : ça fonctionne parfaitement après un reboot, mais ça coince après qu'on ait passé le portable en mode veille (comme décrit dans mon précédent post). Dès que je désactive le pare-feu Windows, ça refonctionne. Pourtant, ce pare-feu ne m'a pas averti d'une connexion à autoriser...

Je n'y comprends rien !

Urmala

Solution pour les problemes de ports pour le multiposte
« Réponse #474 le: 19 janvier 2006 23:52:28 »
Désolé, les gars, votre solution fonctionne peut-être mieux que la mienne si l'on veut pouvoir regarder simultanément la FreeTV sur 2 postes, mais moi, pour l'instant, je n'en ai qu'un...
Et les symptômes sont exactement identiques avec votre config de routeur qu'avec la mienne : ça fonctionne parfaitement après un reboot, mais ça coince après qu'on ait passé le portable en mode veille (comme décrit dans mon précédent post). Dès que je désactive le pare-feu Windows, ça refonctionne. Pourtant, ce pare-feu ne m'a pas averti d'une connexion à autoriser...

Je n'y comprends rien !

kamui

Solution pour les problemes de ports pour le multiposte
« Réponse #475 le: 21 janvier 2006 09:21:53 »
j'ai beau le mettre en veille et le reveiller de la veille sa fonctionne nickel avec mon VAIO 285H en wifi ,le pb viends de chez toi !

dans ton cas je pense que  c un pb de DHCP que t'as , car quand tu te mets en veille , ta carte wifi se mets aussi en veille , et quand tu la reveille et bien tu perds ton IP et tu en obtiens une autre , du qu'ou ta régle de NAT n'est plus valide car elle ne redirige pas sur la bonne IP donc pas de flux TV , donc ta deux possibilités soit claqué les IP en dur sur ta carte wifi , ou soit si tu utilise un firmware alternatif , mets ton routeur en static DHCP , c'est çà dire que le routeur attribueras la même IP à une  addresse MAC renseigné sur le routeur .

moumouman

Solution pour les problemes de ports pour le multiposte
« Réponse #476 le: 22 janvier 2006 00:10:35 »
bonjour, bonsoir,

Jai dl le vlc modifié avec option

je dezippe le fichier et essaie de lancer vlc

Ca réfléchit puis plus rien

Dns gestionnaire des taches: il n'est pas lancé

Rien du tout et jpeux recommencer autant de fois avec le mm résultat

Auriez vous une idée svp??

Merci d'avance

Mickael

retnuts

Solution pour les problemes de ports pour le multiposte
« Réponse #477 le: 22 janvier 2006 14:48:39 »
Bonjour,

Moi, je n'arrive toujours pas à avoir le multiposte:
j'ai ouverts les ports :
http://img24.imageshack.us/img24/5647/ports3tj.jpg
J'ai installé la version bidouillée, mais quand jouvre cette version et que je rentre "http://mafreebox.freebox.fr/freeboxtv/playlist.m3u" , les chaînes défilent(dans la liste) et rien ne s'affiche.
Comment résoudre ce problème ?
cela a-t-il un  rapport avec le fait que je n'ai pas mis d'IP pour le DMZ?

Merci

PS: config : Freebox sert de routeur wifi
                  3 PC dans la maison


Trussart Sébastien

Solution pour les problemes de ports pour le multiposte
« Réponse #478 le: 23 janvier 2006 14:33:01 »
Salut tout le monde,

Le précédent post que j'ai fait, je le précise bien, n'est que pour un seul poste (le mien est en wifi en plus).

Mais tout le monde peut faire le test, et à priori, cela est la seul possibilité pour les routeurs Netgear de petites catégories.

Bon courage à tous.

Je vais faire des tests avec mon deuxième PC ce soir pour voir si cela peut-être utile pour certains d'entre vous.

Je devrais pouvoir poster une réponse demain si tout va bien...

jmme

Solution pour les problemes de ports pour le multiposte
« Réponse #479 le: 23 janvier 2006 23:45:26 »
Bonjour,
j'essaie depuis une semaine de faire marcher vlc. J'ai deux pc avec un routeur wifi airport. Sur un de mes pc, vlc marche très bien, sur mon portable, les chaines défilent sans s'arrêter. J'ai désactivé mon firewall windows et ça à marché pendant 48 heures, depuis les chaines se sont remises à défiler à nouveau en ayant mon firewall de désactivé. Pensez vous que c'est un problème de routeur, et faut il quand même modifier les ports sachant que sur un des mes ordinateurs ça marche. Si quelqu'un peu m'aider, je commence à saturer. Si il s'agit d'un problème de routeur, je ne sais pas comment on modifie les ports avec la station airport mac

merci pour les infos

Trussart Sébastien

Solution pour les problemes de ports pour le multiposte
« Réponse #480 le: 24 janvier 2006 09:34:48 »
Salut jmme,

peux-tu nous donner plus d'éléments sur ta configuration routeur et pc stp ??

Je pense que le routeur dont tu parles est un routeur Netgear (vu son nom)

As-tu fait les modifications sur ton routeur pour les ports 31336-31337 en port forwarding et vu que tu as un deuxième pc les ports 31338-31339 (ou autres) ?

PsYKrO

Solution pour les problemes de ports pour le multiposte
« Réponse #481 le: 24 janvier 2006 13:01:48 »
Citer
et perso je te conseille de changer de firmware car j'ai testé les DD WRT 23 final , çà fait pas long feu avec le P2P , je te conseille Thibor 12 ;) qui est roxx stable sur mon WRT54GS rev 1.1
3 jours de test non stop et aucun problème, donc je reste pour l'instant sur cette version ;)

jmme

Solution pour les problemes de ports pour le multiposte
« Réponse #482 le: 24 janvier 2006 14:09:53 »
Bonjour Le seb,
merci pour ta réponse. Mon routeur est un routeur mac qui marche aussi sur pc, il s'agit de la station airport utilisé sur les mac. Mon problème, c'est que dans la configuration du routeur, je n'arrive pas à trouver les ports correpondants, je ne sais pas dans quels menus il faut aller pour rechercher ces ports. Sinon j'ai la version xp familiale.

Voilà

merci

Trussart Sébastien

Solution pour les problemes de ports pour le multiposte
« Réponse #483 le: 24 janvier 2006 14:39:22 »
Salut jmme,

J'ai un tout petit souci, le terme de Airport (monde Mac) correspond à beaucoup de référence de routeur.

Peux-tu me donner plus de détail (marque, model marqué en dessous, ...) ??

Sinon, je pense que comme beaucoup du doit avoir un problème de redirection des ports vers VLC.

En passant, d'ailleurs, quelle version de VLC as-tu installé, est-ce la version de crazyfred ??

PsYKrO

Solution pour les problemes de ports pour le multiposte
« Réponse #484 le: 24 janvier 2006 15:25:17 »
Si avec ma méthode plus haut ca ne marche pas, je pense que ca peut venir du débit ....
c'est à dire par exemple hier je téléchargeai ... et mon père vient me voir et me dit que la TL marche pas...alors que je sais très bien que ca marche donc pas de problème de configuration...

Alors j'ai limité ma bande passante pour le P2P et mon père a pu y accédé...

Donc pour vos tests, ne faite rien d'autre que le VLC/
++ les gens


retnuts

Solution pour les problemes de ports pour le multiposte
« Réponse #485 le: 24 janvier 2006 17:58:23 »
Pour moi c'est surement un problème de débit (je dl a 300ko/s)
Mais, j'arrive a voir les chaines free sur la télé(même si elles freezes un peu)

RichY309

Solution pour les problemes de ports pour le multiposte
« Réponse #486 le: 24 janvier 2006 22:10:12 »
Testé et approuvé avec WTR54GC, merci beaucoup ;)

th_vador

Solution pour les problemes de ports pour le multiposte
« Réponse #487 le: 25 janvier 2006 15:20:24 »
Bonjour à tous!

J'ai récupéré la version VLC de crazyfred, et j'ai redirigé les ports 31336 & 31337 de mon routeur (WRT54GS) vers l'IP de mon PC (IP fixe).
J'arrive à regarder une chaîne (changer de chaîne, enregistrer et tout et tout) sur le pc, mais le problème, c'est que, régulièrement, l'image se détériore.  

Je ne sais pas trop comment expliquer ça (c'est assez visuel en fait...). Disons que tout est nickel pendant quelques minutes, puis l'espace d'une seconde l'image se brouille (ou plutôt se mélange les pixels), ensuite tout redevient normal (ça ne dure vraiment qu'une seconde (et encore!)), puis ça recommence... etc...  Et bien entendu, cela n'est pas du tout le cas quand il n'y a pas de routeur...

Est ce que certains d'entre vous ont rencontré un problème similaire? (si oui, vous l'avez réglé comment?)

Je n'ai rien fait du tout vis-à-vis du port 554... Est ce que ça pourrait venir de là? (d'ailleurs, j'ai pas bien compris à quoi il sert celui là...)

Merci d'avance pour votre aide.

jmme

Solution pour les problemes de ports pour le multiposte
« Réponse #488 le: 25 janvier 2006 21:47:38 »
bonjour le seb,

je n'ai pas pu répondre avant désolé, ma airport station a la config suivante:

airport express base station
model n°a1084
fccid bcga1084

je ne sais pas si info peuvent en tout cas merci pour le coup de main

jmme

PsYKrO

Solution pour les problemes de ports pour le multiposte
« Réponse #489 le: 26 janvier 2006 08:19:17 »
th_vador >> c'est tout à fait normal ... ca dépend de la distance de chez toi par rapport à ton DSLAM. et aussi de ton débit... si tu telecharges ca peut etre la cause de ton problème...

Sinon moi aussi ca m'arrive d'avoir de temps en temps des rayures ...

Trussart Sébastien

Solution pour les problemes de ports pour le multiposte
« Réponse #490 le: 26 janvier 2006 14:08:35 »
Salut jmme,

Je viens de trouver cela sur le web : http://www.zdnet.fr/produits/materiels/accessoires_mobiles/0,49050633,39158006,00.htm

Je pense que ça doit correspondre à ton routeur.

Ceci dit, comme ils le mettent dans les (-) "La configuration n’est pas basée sur un navigateur, pas de pare-feu SPI, impossible de configurer le filtrage des ports, pas d’interface intégrée pour le contrôle du son.

Je sais pas si tu vas pouvoir y arriver avec ce routeur ...

Bon courage dans ta recherche quand même...

jiel

Solution pour les problemes de ports pour le multiposte
« Réponse #491 le: 28 janvier 2006 14:37:11 »
J'ai installé la version crazy avec option, mais je n'ai que la liste des chaines qui défilent, qui défilent, qui défilent...
Je suis en mode routeur sur la fb. J'ai bien routé les ports UDP 31336 et 31337 vers le PC concerné.
Je suis probablement aveugle, mais où déclare t on les ports dans VLC ? Je n'ai pas trouvé où faire la modif dans le menu "paramètres", puis "préférences"... même en cochant l'onglet paramètres avancés dans les différents écrans possibles.
Merci de votre aide.


loopkinn

Solution pour les problemes de ports pour le multiposte
« Réponse #492 le: 28 janvier 2006 15:12:16 »
Bonjour, Après avoir lu ce post dans tous les sens ainsi que d'autres, je n'arrive pas a voir quoi que ce soit dans VLC, même pas la liste des chaines. Ma config est la suivante :
FB V4
Routeur Linksys WRT54G avec le firmware d'origine (V4.01.1)
Le PC en ethernet sur le routeur avec XP SP2 (firewall désactivé)
VLC modifié par Crazyfred.

J'ai validé les CGV depuis déja longtemps, rebooté la FB, forwardé en UDP un port (31336) sur l'IP de mon de PC dans l'interface du routeur et mis ce même port dans les options de VLC (UDP Port (beta-crazy)). Un ping sur "mafreebox.freebox.fr" fonctionne et le firewall de mon antivirus n'est pas actif.

Je rentre http://mafreebox.freebox.fr/freeboxtv/playlist.m3u dans "ouvrir un fichier avancé" de VLC et rien ne se passe. J'ouvre la fenêtre "liste de lecture" de VLC et aucune liste de chaînes n'apparait. L'onglet général contient bien l'url de la playlist, mais rien d'autre.

Quelque chose m'aurait-il echappé ? Merci de votre réponse.

Loopkinn

jholvoet

Solution pour les problemes de ports pour le multiposte
« Réponse #493 le: 28 janvier 2006 19:59:26 »
Bonjour à tous,
L'initiative d'Armelle me parait assez bonne, à savoir conserver un post de référence qui déroule de façon précise toutes les étapes du processus, et qui serait "alimenté" par les discussions du présent post (nouveaux problèmes, solutions, ...). Quelqu'un serait-il prêt à maintenir ce post ?

Perso j'ai enfin réussi à avoir la télé sur un PC en cochant l'option de VLC "Flux de sortie" dans l'ouverture de l'URL  et en suivant ce qui est justement indiqué dans le post d'Armelle (p19, merci à toi !). Par contre ces paramètres sont effacés à chaque réouverture de VLC, ce qui est plutot pénible. Quelqu'un sait-il comment les conserver ? Est-il possible de faire un .bat qui permet de lancer un VLC tout configuré avec l'URL et tout ?

Merci d'avance pour votre aide

jholvoet

Solution pour les problemes de ports pour le multiposte
« Réponse #494 le: 28 janvier 2006 20:01:11 »
Loopkinn,
J'avais ce problème, un simple "débranche" de la freebox l'a résolu. J'espère que ce sera aussi simple pour toi :-)

loopkinn

Solution pour les problemes de ports pour le multiposte
« Réponse #495 le: 28 janvier 2006 20:29:06 »
Citation de: jholvoet
Loopkin,
J'avais ce problème, un simple "débranche" de la freebox l'a résolu. J'espère que ce sera aussi simple pour toi :-)
Nickel et si simple ! Je me suis cassé la tête pour pas grand chose. Merci

yellowsub122

Solution pour les problemes de ports pour le multiposte
« Réponse #496 le: 29 janvier 2006 19:57:30 »
Bonjour tt le monde.

je me permets de vous contacter car j'ai aussi un pb que bcp semble avoir également.
La télé Free marche nickel avec lorsque mon pc est "câblé" à mon routeur Linksys mais rien en en wi fi.

Voici ma config:
free box v4  
VLC: version de Crazy avec options
Routeur Linksys WRT54G firmware v2.02.2, rebooté récemment.
Conditions générales acceptées.
Sur le routeur, j'a bien fait le port forwarding sur les 2 ports (31336 et 31337) vers l'@IP fixe de mon pc qui a le pare feu windows.
Si le PC est en éthernet, pas de pb, ça marche. J'ai bien la télé free.
Si le pc est en wi fi, rien ne marche...

Pouvez-vous m'aider svp ?
Merci.

PsYKrO

Solution pour les problemes de ports pour le multiposte
« Réponse #497 le: 30 janvier 2006 12:32:59 »
Simple question....

Est ce que tu rediriges bien sur l'IP de carte wifi?

Si tu as comme sur un portable 2 cartes reseaux c'est à dire une carte ethernet et une carte wifi... tu es obligé d'avoir 2 @IP (fixe de préférence) différentes...

Apres sur ton lynksys, redirige comme tu viens de le faire  en port forwarding en prenant 31338 et 31339 (modifie ton vlc  crazyfred)

tu devrais avoir : VLC 1 =  31336 - 31337 UDP 192.168.1.x activer et VLC 2 = 31338 - 31339 UDP 192.168.1.x (wifi)
Apres suivant quel type de connection tu utilises, il suffira juste de modifier le port dans VLC crazy

Enfin tout ca, si tu as 2 cartes réseaus sur le meme pc...


Je pense sincèrement que tu n'as pas mis de redirection pour la carte wifi... car chez moi ca marche nikel (wifi + ethernet + 3 PC en meme temps)

Bon courage, la vérité n'est pas très loin ... ;)

PsYKrO

Solution pour les problemes de ports pour le multiposte
« Réponse #498 le: 30 janvier 2006 12:39:33 »
jholvoet >>oui bien sure ! Utilise le skin Freevcr il me semble...relie les posts précédent, j'en parle il me semble... et en plus c'est plus conviviale car tu as les images des chaines ...c'est pas grand chose... mais c'est mieux que d'avoir une playlist toute bête....


rangit

Solution pour les problemes de ports pour le multiposte
« Réponse #499 le: 30 janvier 2006 15:10:38 »
je c pa commant ouvrire les port avec mon routeur d-mink di-604
si quel un pouvai maider merci