Free - Messagerie et hébergement > Hébergement : pages persos et blogs

défaut sur page indexée ".htaccess"

(1/3) > >>

mm91:
Bonjour,

Depuis hier (6 déc. 2018), une (seule) page de mon site perso est très longue à s'afficher (mini 30 secondes, alors qu'aucune autre page Internet n'est aussi longue, sur mon site ou ailleurs);

La page fini bien par s'afficher malgré le message: "Le délai d'attente est dépassé", mais le navigateur continu à chercher la page.

Il s'agit du seul sous répertoire de mon site comprenant une page d'index avec une page ".htaccess" (comprenant seulement l'instruction: "Options Indexes")

Ceci n'est pas rédhibitoire, mais cette page fonctionnait normalement depuis plusieurs années.


Y a-t-il eu quelque chose de changé chez Free récemment  ?

merci

mm91:
Merci pour votre réponse.

Dans l'absolu je veux bien mais le changement a été brusque.

Je pense qu'il s'est passé quelque chose chez free d'autant plus que j'avais déjà eu des problèmes avec cette page d'index que j'avais du modifier (sur les conseils de ce forum)

Pour tout le reste de mon site les problèmes côté Free sont plutôt rares (depuis 15 ans)

mm91:

--- Citation de: ghecDes3 le 07 décembre 2018  16:10:46 ---Si ce répertoire contient un grand nombre de fichiers/répertoires, la génération de la page d'index peut être longue en effet. Ne pas oublier également que votre site est hébergé sur un serveur mutualisé dont les ressources sont partagées par des centaines d'autres comptes, qui peuvent, eux aussi, être la cause du ralentissement de votre site.

--- Fin de citation ---

Bonjour,

Je viens de faire l'essai en réduisant (provisoirement) à un seul (au lieu de 180) le nombre de fichiers de cette page d'index (comprenant toujours le fichier .htaccess)

Le temps d'accès (et mon navigateur qui continue à chercher) est resté le même (environ 45 secondes)

Ce n'est donc pas une question de nombre de fichiers.

Quand à la suggestion du serveur mutualisé, je rappelle que ce défaut (disons plutôt cette gène) ne se produit que sur cette pages alors que mon site contient des milliers d'autres pages qui fonctionnent parfaitement.

J'en reviens tout de même au problème du .htaccess car cette page s'était mise à ne plus fonctionner du tout et ce n'est qu'en rajoutant le .htaccess (sur les conseils de ce forum) qu'elle fonctionnait (parfaitement) de nouveau,
puis, maintenant avec ce délai (et ce blocage) gênant.

Difficile de penser qu'il n'y a pas un rapport de cause à effet ?

Ou autre explication ?

fabfree:
Et en adressant directement la page cible? Et sans .htaccess?

mm91:

--- Citation de: fabfree le 21 décembre 2018  19:46:36 ---Et en adressant directement la page cible? Et sans .htaccess?

--- Fin de citation ---

Non, si j'enlève le .htaccess je n'ai plus du tout accès à la page (erreur 403);
comme cela s'était produit quand j'avais posté ce message en septembre 2014 et que j'avais résolu le pb en mettant le .htaccess :

https://forum.freenews.fr/index.php?topic=98457.msg1154246#msg1154246

mais le problème actuel ne vient peut-être pas de là,
c'est juste que c'est la seule page qui m'avait déjà posé des problèmes.

Navigation

[0] Index des messages

[#] Page suivante

Utiliser la version classique